Amazon Fire

Smart Launcher is not compatible with Amazon devices.

Unfortunately Amazon devices (Fire tablets and phones) run a modified version of Android that is not designed to work with third party launcher like Smart Launcher. Because of this, Smart Launcher is not officially supported by Amazon devices.

Depending on your device model, you could be able to find some workaround this limitation, however since we never tested such methods we cannot provide you more details.

‚Äč